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1. Description of AdvancEd environment 

1.1 Purposes and application areas 

AdvancEd is intended to develop and verify NC flow programs of any ISO-7bit 

version (ISO-6893, DIN-66025). During the work it delivers context-dependent help, 

concerned with the syntax and command set of some concrete ISO-7bit version. It 

carries out syntactical and, partly, semantic checking of flow program blocks, being 

inputted. AdvancEd makes it possible: to create flow programs; to assemble them 

from ready-made blocks; to introduce changes into earlier flow programs, developed 

with the help of CAM-systems; to verify the tool trajectory. 

AdvancEd could be either resident in the NC system or some independent 

system in the department, developing flow programs. 

2. Setting and starting AdvancEd 

2.1 Setting  AdvancEd 

For installation it is necessary to start the file  setup.exe and follow instructions 

of the setting wizard. The setting program is described in the file    "Setting_NC_ 

Editor.doc", which is included into the setup kit. 

2.2 Short description of  AdvancEd files 

When the installation procedure is finished, there is created the structure of 

folders with the following subdirectories.   

BIN contains executive *.exe files, dynamic *.dll libraries and     

ActiveX *.ocx components; 

CFG the subdirectory  of setup files;   

ENU the subdirectory of files, supporting the English language;   

ENU\BMP the subdirectory of files with context graphical help in the 

English language;   

DEU the subdirectory of files, supporting the German language;    

DEU\BMP the subdirectory of files with context graphical help in the 

German language;  

RUS the subdirectory of files, supporting the Russian language;   
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RUS\BMP the subdirectory of files with context graphical help in the 

Russian   language;  

NCS the subdirectory of flow program files.   

During its work   AdvancEd uses the following files. 

ncedtcln.exe the executive file of the program; 

cfgedit.exe the executive file   *.cfg of the editor of configuration files; 

*.ini the file of parameters, setting AdvancEd up. It can be 

defined like a parameter at starting the program. If the file 

is not defined so, there is used the file  NcEdtCln.ini in the 

directory  Windows. 

*.cfg the file, setting   AdvancEd up for the concrete version of 

the flow program language. It must be defined like a 

parameter   sCfgFile= either in the  *.inii file, or in the 

command line. If such a parameter is absent, the editor 

tries to use the file  "..\cfg\andronic_400_enu.cfg"; 

*.bmp, *.wmf files of the context graphical help;   

*.hlp, *.cnt files of the help subsystem;   

*.doc documentation files;  

*.ncs, *.cnc, *.nc flow program files;   

*.ipd files of the interpolator data.   

2.3 Starting  AdvancEd 

After installation of  AdvancEd with the help of the installation program, it is 

possible to start the program by means either the menu Start or the icon on the 

desktop (if the icon has been created).   

It is also possible to start AdvancEd from the command line. For this purpose: 

click the button Start and choose the command Run; write in the text field Open, the 

command NcEdtCln.exe, starting the program. In this case it is possible to use 

parameters, defined in the command line. To get help for parameters, use the key  

/?. 

If starting without parameters, the editor uses the file NcEdtCln.ini for setting 

up. At the first start the editor creates this file with parameters, used by default. It 

also tries to use the configuration file «..\cfg\andronic_400.cfg», which sets up  the 

language of flow programs. If such a file is absent, it is possible to work only in the 
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text editor mode, without inputting flow program blocks from the panel and without 

using graphical help.        

2.4 Parameters of the command line 

When starting AdvancEd from the command line, the following parameters 

and keys can be used.    

NcEdtCln.exe [/?] ["edit file"] [/c"cfg file"] [/i"ini file"] [/s###x###] [/l] [/v] [/p] 

/? - it is used to get help for parameters and keys, used in the 

command line;   

edit file - the name of the file, which will be edited;   

/c - there is defined the name of the file, which sets up the 

concrete version of the flow program language;   

 cfg file  - the name of the file with the extension *.cfg. If the extension 

is absent, it will be added.   

/i - there is defined the name of the file with setup parameters of   

AdvancEd. 

ini file  - the name of the file with the extension *.ini. If the extension is 

absent, it will be added.   

/s###x### - the size of the program window;   ### - the number, defining 

the horizontal and/or vertical size in pixels. The program works 

with fixed window sizes 800x600 and 1024x768 pixels. It is 

possible to enter only values of a horizontal size. For example 

(/s1024 instead of /s1024x768). 

/l -in this mode it is possible to work with only one document. 

There will be changed values of keys F9 and F10 to finish the 

work and to save the program. This condition is used at 

operation on NC system. 

/v -the prohibition for changing the text of the flow program; It is 

impossible to save an active file with the same name. 

/p -printing the file, defined by the parameter "edit file" without 

starting the application.   

Parameters, which are in square brackets  [], are not obligatory.    

Short file names could be defined without quotation marks; but long names, 

especially with blanks, must be enclosed in double quotation marks.   
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3. Work in AdvancEd environment 

In the process of work with   AdvancEd a user can do the following:   

�� to load the file (to create a new file) of the flow program;     

�� to edit flow program blocks;   

�� to load (or to save) groups of the flow program blocks;  

�� to print the text of the flow program;   

�� to receive blocks of the flow program from the NC system;   

�� to simulate the tool trajectory in order to estimate results of work;   

�� to save the flow program in the same (or in some new) file.   

3.1 User interface 

AdvancEd has an interface of the standard multi-document Windows-

application (permitting to edit several documents concurrently). The interface 

includes: 

�� display windows, intended: to edit flow programs, to reflect the context 

reference information or the contents of the interpolation data file; 

�� document frames, uniting display windows for the given document; 

�� context-dependent ToolBars and menus, intended to choose the work 

modes and initiate commands; 

�� the Status Bar, reflecting information about the process of editing; 

�� dialogue windows, intended to accept setups and parameters of complex 

commands. 

 AdvancEd commands could be initiated with the help of either the menu or 

Toolbars. The menu contains the whole set of ToolBar commands. 
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Menu View windowsFrames of docu-ments

Status Bar Dialogue window Toolbar  

Pic. 1 User interface 

3.1.1 Windows and documents 

Two types of files are documents for AdvancEd: (see Short description of  

AdvancEd files): 

�� files of ISO-7bit flow programs; 

�� files of the interpolator data. 

During the work it is possible to open and close documents of both types; but 

only files of flow programs could be created, modified and saved at the disk. There is 

a possibility to work with the document contents in view windows, united in the frame 

of the document (see א). The number and purposes of view windows depend upon 

the chosen mode for this document (see AdvancEd modes). 

AdvancEd does not have constraints, connected with the volume of the file of 

the flow program document. But one thing should be taken into consideration: to 
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work with the document of large volume means to have twice more free space at the 

disk as compared with the volume of the document itself. When opening the 

document of the flow program, it is assumed, that it has the standard text format, i.e. 

it consists of lines with «CR LF» at their end. AdvancEd admits also, that the lines 

are finished with symbols «CR», «LF», «LF CR». At opening such documents, they 

are being transformed into the standard text format with «CR LF» symbols (ASCII 

value of the symbol CR is 0x0D, and the value of the symbol LF is 0x0A). 

A new document of the flow program is being create by the menu command 

«File>New». The existing document could be opened with the help of the menu 

command «File>Open». The document could be chosen from the list of documents, 

having been previously opened, - «File>1 File1.NCS», «File>2 File2.NCS». It is 

possible to do it either with help of the menu or with the help of the toolbar managing 

the file sytem, this ToolBar must be invoked with the help of either the “F9” key or the 

corresponding button of the standard control panel. 

At the first start AdvancEd is being registered like an application, opening files 

with extensions *.ncs and *.ipd; this makes it possible to open such files from 

windows, Explorer and File Manager. The document of the flow program, being 

edited, could be saved with the same name by the menu command «File>Save»; it 

could be also saved with some other name by the menu command «File>Save 

as...». It could also be done with the help of the dialogue window, intended to load 

and save the edited file. The document could be closed either by the menu 

command «File>Close» or closing the frame of the document. Menu command 

«File>Exit» exits AdvancEd. The position of document frames at the screen could be 

arranged in the following way: 

�� like a cascade, by the menu command «Window>Cascade»; 

�� like vertical mosaic, by the menu command «Window> Tile vertical»; 

�� like the horizontal mosaic, by the menu command «Window> Tile 

horizontal». 

The document frame could be chosen from the list of frames, having been 

previously opened, - «Window>1 File1.NCS», «Window>2 File2.NCS». 

3.1.2 ToolBars and menu 

ToolBars are context-dependent both on the document type (see Windows 

and documents) and the work mode (see AdvancEd modes). The corresponding 



User reference manual Date: 23.09.02  File: AdvancEd User Reference Manual.doc Page:  10 

ToolBar is being loaded, when opening a document or changing a mode. Activity of 

corresponding keys depends upon the mode. The commands could be initiated in 

one of three ways: 

�� by clicking the mouse at the corresponding key; 

�� by pushing the corresponding functional key «F1» ... «F10»; 

Keys of ToolBars could be divided into two groups: keys-commands and keys-

flags. If the key-command has been pushed, it sinks for some time and the 

corresponding command is being initiated. The state of the key-flag (is sunk, is not 

sunk) reflects some mode or activity of the corresponding dialogue. 

Switching ToolBars on-off is carried out by the menu flag «View>Toolbar». 

The AdvancEd menu contains the full set of ToolBars’ commands, duplicating 

such commands. The menu is also context-dependent on the document type (see 

Windows and documents) and the work mode (see AdvancEd modes). The type of 

the document defines, whether corresponding commands are present or absent; and 

the work mode defines activity of such commands. 

Like keys of ToolBars, the items of the menu could be divided into two groups: 

items-commands and items-flags. the behavior of these groups is the same as the 

behavior of groups of ToolBars’ keys. 

All menu commands could be chosen by combinations of keys, the key «Alt» 

plus keys-accelerators. Keys accelerators are underlined in menu items. If some 

menu item has been opened, it is necessary to hold the «Alt» key no longer. For 

instance, it is possible to invoke the dialogue, intended to open a file, pushing the key 

combination «Alt+F» and the key «O». The most often used menu items show such 

combinations of accelerators, which commands do not require the menu. For 

instance: «Ctrl+O» (Open file), «Ctrl+S» (Save file), «Shift+Ins» (Insert block), etc. 

3.1.3 Status Bar 

The Status Bar is divided into seven sections (see ב), which reflect: the state 

of AdvancEd, information about long-time processes, types of search and 

substitution, information about moving from the beginning to the end of some very 

long file. The menu flag «View>Status Bar» is used to switch on-off the Status Bar. 
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Section: regime of work of keyboard, "NumPad"

Section: regime of locking the top register of keyboard

Section: regime of insert-substitution

Section: state of verification process

Section: cursor coordinates

Section: information about long-time processes

Section: messages

 

Pic. 2. The Status Bar 

3.2  AdvancEd modes 

AdvancEd submits the following modes for flow program documents: 

�� editing in the full-screen text editor (see ג); 

�� editing in the editor with the address panel and context graphical help (see 

 ;(ד

�� receiving flow program blocks from the NC system; 

�� verifying the tool trajectory (see ה). 

For documents of interpolator data the only full-screen view mode is possible 

(see ו). 

When opening the flow program document, the user is able to switch different 

edit modes for this document. This switching influences upon the number and 

arrangement of view windows in the frame of the document (see Windows and 

documents), and also on the substitution of the context ToolBar (see ToolBars and 

menu). When opening the flow program document, there is being set either the mode 

of the full-screen text editor, or the mode of the editor with the address panel. It 

depends upon, what of this modes was used in the last edit session. Switching from 

the mode of the full-screen editor to the editor with the address panel is being carried 

out either by means of setting the menu flag «View>Watch», or from the ToolBar. 

The transition back is being carried out either by deleting the flag, or from the 

Toolbar.  

The key F8, or the corresponding ToolBar button, changes the focus between 

the text editor window and the address panel.   
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When editing in the mode of the address panel, it is possible to receive the 

flow program blocks from the NC system. Transition to the teaching mode is made by 

setting the flag of the menu   «NC system>Teaching mode». To switch off, this flag 

should be deleted. The start and stopping of a teaching mode also is fulfilled by the 

button on the toolbar or "«F7" key. 

The transition to the tool-trajectory verification mode is possible both from the 

full-screen edit mode and from the edit mode with the address panel. This transition 

is initiated either by the menu command «Simulate>Simulate mode», or from the 

ToolBar. Return back to the edit mode is initiated either by the menu command 

«Simulate>Edit mode», or from the ToolBar.  

 

Pic. 3. The full-screen text editor 
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address panel Help window

 

Pic. 4. The editor with the address panel and context graphical help 
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Pic. 5. The verification of the tool-trajectory 
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Pic. 6. Looking through the interpolator data 

3.3 Editing and verifying flow programs 

3.3.1 Editing flow programs 

Flow program blocks could be edited either in the text editor or with the help of 

the address panel. In any edit mode of AdvancEd the menu command «View>G-

vector» could be used to calculate the current G-vector, i.e. the aggregate of active 

modal G-functions. 

3.3.1.1 Text editor 

In the window of the text editor there exist possibilities to move along the flow 

program text, to edit current lines or add new flow program lines. For moving along 

there are used keys, described in the א. 
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Table 1. Keys for moving along the text 

Key or combination of keys Cursor movement 

arrow «Up» one line up 

arrow «Down» one line down 

arrow «Right» one symbol right 

«Ctrl»+ arrow «Right» one word right 

arrow «Left» one symbol left 

«Ctrl»+ arrow «Left» one word left 

«Home» to the beginning of the line 

«Ctrl»+«Home» to the beginning of the document 

«End» to the end of the line 

«Ctrl»+«End» to the end of the document 

«Page Up» one page up 

«Ctrl»+«Page Up» to the first line in the page 

«Page Down» one page down 

«Ctrl»+«Page Down» to the last line in the page 

 

For deleting, the text editor needs the following keys, described in the ב. 

Table 2. Keys, intended to delete symbols 

Key or combination of keys Action 

«Backspace» deletes the left symbol from the cursor  

«Delete» deletes the right symbol from the cursor 

«Ctrl»+«Delete». Deletes the whole line 

 

The key «Enter» is used to add a new line or to break the line in the cursor 

position. 

Blanks are being added into the current cursor position in the edit window, 

when pushing the key «Tab». The number of blanks could be set. 

Abnormally carried out operation can be abolished by the menu command « 

Editing > Undo» or shortcut key «Crtl+Z». The sequential realisation of this command 

cancels all the earlier carried out operations. 

The first possibility to input symbols into the line is to use the insert regime, 
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when inputted symbols are being added to the current cursor position, shifting those, 

which exist. The second possibility to input symbols into the line is to use the 

substitution regime, when the inputted symbols substitute those, which exist. 

Switching between insert-substitution regimes is being carried out either by means of 

setting-deleting the menu flag «Edit>Insert». The cursor in the insert regime looks 

like the thin rectangular; while in the substitution regime it looks like the broad 

rectangular. The process of switching on the insert regime is reflected in the Status 

Bar section of insert-substitution (see Status Bar). 

The window of text editor could be divided into two or four sub-windows (see 

 ,in case if different parts of the flow program document are to be edited. Changes ,(ז

included in one of sub-windows, are being duplicated in other sub-windows. Dividing 

the window could be fulfilled either with the help of dividing elements, or by means of 

the menu command «Window>Split». To delete dividing, it is necessary to click the 

mouse twice at the border of dividing. 

 AdvancEd has the following constraint: the input line should not be longer, 

than 1024 symbols, including not visible symbols «CR LF». A special warning 

accompanies an attempt to exceed this constraint. 
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Dividing elements Borders of division

Sub windows  

Pic. 7. Dividing the window of the text editor 

When editing in the window of the text editor both in the full-screen mode and 

in the mode with the address panel (see AdvancEd modes), there appears the 

context-dependent ToolBar; its keys are shown in the ג. 
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Table 3. Keys of the text editor ToolBar 

Key Purpose 

«F1 Block» Switching on the work with blocks 

«F2 Simulate» / 

«F2 Del» 

Transition to the debug mode or deleting the line if the debug 

mode is not supposed in this application 

«F3 Goto» Invoking the dialogue for transition to a line  

«F4 Watch» Switching between modes, the full-screen editor and the editor 

with the address panel  

«F5 Search» Invoking the dialogue window for search-substitution  

«F6 G_Vector» Calculating the G-vector for the current block 

«F7 Teach» Starting the teaching mode 

«F8 Mode» Contra-clockwise switching between windows, the text editor, 

the address panel, the ToolBar. «Shift+F8» - the same, but 

clockwise.  

«F9 File» \ «F9 

Abort» 

The transition to the mode of working with files; or exiting the 

program without saving the file, if the parameter -l of the 

command line has been set 

«F10 End» Exit out of the flow program 

The text editor is able to print out the flow program with the help of the menu 

command  «File>Print». See additional information for the Print mode in Printing 

mode. 

3.3.1.1.1 The dialogue window, intended for the transition to a line  

The dialogue window, intended for the transition to a line, is used for quick 

removal to a line with any number (see ח). This dialogue window could be invoked 

either by the accelerator «Ctrl+G», or by the menu command «Edit>Goto line», or by 

means of the Toolbar. 
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Pic. 8. The dialogue window, intended for the transition to a line 

In case the radio-button «Absolute» has chosen the absolute transition, the 

direction radio-buttons «Goto UP» and «Goto DOWN» become inactive, and the 

absolute line number should be inputted into the field «Line number». In case the 

radio-button «Relative» has chosen the relative transition, the direction should be 

defined by radio-buttons either «Goto UP» or «Goto DOWN», and the number of 

transition lines should be inputted into the field «Line number». If the transition is 

initiated by the button «Goto», the dialogue window stays open, and it is possible 

therefore to realise the relative transition several times in succession.  

3.3.1.1.2 The search-replace dialogue window 

The search-replace dialogue window is used either for searching or for 

searching with replacing the given number of the sub-line insertions in the flow 

program document (see ט). This dialogue window could be invoked either by the 

accelerator «Ctrl+F», or by the menu command «Edit>Search», or by means of the 

ToolBar.  



User reference manual Date: 23.09.02  File: AdvancEd User Reference Manual.doc Page:  21 

 

Pic. 9. The search-replace dialogue window 

The sub-line to be found should be inputted into the field «Find what», and the 

sub-line, replacing one to be found, should be inputted into the field «Replace with» 

Thirty two sub-lines, used in previous sessions, are being opened in both lists of 

fields, «Find what» and «Replace with». The flag «Match case» should be set, if it is 

necessary to take into consideration the register of symbols of the sought sub-line 

and lines of the flow program document. The flag «Whole words» should be set, if it 

is necessary to search such insertions of the sought sub-line, which are separated 

from the rest text by generalized blanks. When the flag «Replace» has been set, the 

field «Replace with» and the flag «Ask for replace» becomes active. If the flag «Ask 

for replace» has been set and the sought sub-line is found, there is issued a request 

for its replacing. When the number of insertions of the sought sub-line becomes 

equal to the value in the field «Number of contents», the replace operation stops. If 

the flag «All entry» has been set, the field «Number of occurrences» becomes 

inactive. 

If the button «Search» is used for searching, the dialogue window stays open, 

and therefore searching could be realised several times in succession.  
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3.3.1.1.3 Operation with files 

There exists a possibility to work with files by means of   the menu  «File», or  

with the help  of the ToolBar, appearing in the  File mode.   Purposes of buttons are 

shown in the.ד The button «F9 File» initiates the transition to this mode. 

Table 4 ToolBar keys intended to work with files 

Key Purpose 

«F1 New» Opening an empty window for creation of a new file 

«F2 Open» Opening the file in order to edit it 

«F3 Save» Saving the file with the current name. If the new file has no 

name yet, then, the standard dialogue for saving a file will be 

opened. 

«F4 Save As» Saving the file with a new name 

«F5 Close» Closing the current window. If the file in the window has been 

changed, saving the file will be suggested 

«F6 Restore» Restoring the initial text of the edited file 

«F7 »  

«F8 »  

«F9 File» Exiting the File mode and return to edit mode 

«F10 End» Exit out of the flow program 

3.3.1.1.4 Block operations 

The text editor AdvancEd is able to fulfil the expanded set of block operations. 

For this purpose the special ToolBar is being switched on, with keys, described in the 

  .ה
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Table 5. ToolBar keys for block operations 

Key Purpose 

«F1 Block» Switching off the work with blocks 

«F2 Mark» Switching on the regime of marking, without the key «Shift» 

«F3 Goto» Invoking the dialogue for transition to the line  

«F4 Cut» Cutting the block 

«F5 Copy» Copying the block 

«F6 Paste» Pasting the block 

«F7 Scale» Scaling axes values in the block 

«F8 Renum.» Re-numerating flow program blocks in the block 

«F9 Load» Invoking the dialogue window, intended to load the block from 

the file  

«F10 Save» Invoking the dialogue window, intended to save the block in 

the file 

The block could be marked in different ways: in a standard way, moving along 

the text with holding either the button  «Shift» or the left mouse button; in a special 

marking mode (see «F2 Mark» in ה), which emulates holding the button  «Shift». The 

following operations could be carried out over the marked block:  

�� the menu command «Edit>Cut», cutting into the exchange buffer;  

�� the menu command «Edit>Copy», copying into the exchange buffer;  

�� scaling axes values in the block (see The dialogue window of scaling);  

�� re-numerating flow program blocks in the block (see The dialogue window 

of re-numerating blocks);  

�� the menu command «Edit>Save block», saving in the file at the disk.  

Besides, the menu commands «Edit>Paste» and «Edit>Load block» make it 

possible to paste the block, which was copied earlier; and to load the block from the 

file at the disk. All operations with blocks are available by means of the context 

menu, being invoked by the right mouse button. 

3.3.1.1.4.1 The dialogue window of re-numerating blocks 

The dialogue window of re-numerating blocks is used to set, delete and 

correct numbers of the flow program blocks in the marked block (see י). This dialogue 

window could be invoked, after marking the block, either by the menu command 
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«Edit>Renumerate block»; or by means of the ToolBar, intended to work with blocks.  

 

Pic. 10. The dialogue window of re-numerating blocks 

The value, starting re-numeration, should be inputted into the field «Start 

from:». The re-numeration step should be pointed out in the field «Step:» After 

pushing the key «Clear», all numbers of flow program blocks are being deleted in the 

marked block.  

3.3.1.1.4.2 The dialogue window of scaling 

The dialogue window of scaling is used to scale axes values in the marked 

block. Besides, axes values in the marked block could be automatically re-calculated, 

when changing measure units (for instance, when substituting inches for millimetres, 

see אי). This dialogue window could be invoked, after marking the block, either by the 

menu command «Edit>Scale block», or by means of the ToolBar, intended to work 

with blocks.  

 

Pic. 11. The dialogue window of scaling 
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The value of the scale coefficient might be either inputted into the field «Scale 

factor:»; or calculated automatically, when choosing the corresponding radio-buttons 

(for different measure units) in groups «From:» and «To:». 

3.3.1.2 Printing mode 

The printing mode provides the output of the flow program text to the printer 

or some other printing device.  This mode is available only from the window of editing 

the flow program. This mode has four main divisions.    

1.Page setup.   

2.Print. 

3.Print setup. 

4.Print preview. 

3.3.1.2.1  Page setup  

The page setup dialogue is intended to define parameters of the page, used 

for printing the document.   

The menu «File>Page Setup» is intended to invoke the standard dialogue for 

setting up page parameters. Dialogue fields Left, Right, Top and Bottom define 

borders of the printing area accordingly.  Setup data will be saved in the initialization 

file. In all other points, the dialogue behavior is standard.     

 

Pic. 12 The dialogue of setting up page parameters 
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3.3.1.2.2 Print 

The print dialogue is intended to choose the type of the printer and to define 

parameters of printing the document.   

For more convenient work with the document, the top running head, 

containing the page number and the file name, will be printed automatically (see גי).    

The peculiarity of the Print mode is the following: when printing file lines, 

exceeding the print area, the words will be shifted to the next line automatically.   If 

one page is enough for the whole document, the field  «Pages» will be deactivated. 

In all other points, the dialogue behavior is standard.   
The standard print dialogue window could be opened from the menu 

«File>Print» (see גי).   

 

Pic. 13 The print dialogue 

3.3.1.2.3 Print setup  

The corresponding dialogue is intended to setup print parameters.   

 The menu  «File>Print Setup» is intended to invoke the standard print 

dialogue (see די).   The behavior of the dialogue is standard.   
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Pic. 14 The print setup dialogue 

3.3.1.2.4 Print preview 

The print preview mode is intended to preliminary look through the 

document, which will be printed.   

This mode is standard. It is possible to preview one page or two pages, with 

scaling or without it.      

The menu   «File>Print Preview» is used to invoke the preview mode (see 

  .The behavior of the mode is standard .(וט
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Pic. 15 The preview mode. 

3.3.1.3 The address panel 

The address panel is especially necessary, when editing flow programs by 

means of the special operator panel (for instance, NC system operator panel). The 

reason is, that normally, the operator panel has a restricted set alphabetical keys, 

and this inconveniences the work with some usual text editor. The address panel 

together with the context graphical help make it possible to realise syntactical and 

partly semantic checking of inputted blocks. When working with the address panel, 

the line of the current edited block in the text editor is lightened; and the 

corresponding ToolBar appears, with key purposes, described in the ו. Keys «Tab», 

«Up» and «Down» execute displacement between input fields of the address panel. 

In the process of displacements, in the StatusBar message section (see Status Bar), 

there are outputted prompts about the purpose of the address current input field. A 

new block is inputted in the insert regime, when pushing the key «Enter» of the 

address panel. The transition to a next block takes place in the replace regime, when 

pushing the key «Enter» of the address panel. The layout of fields in the address 

panel should be defined in the configuration file, setting up AdvancEd for some 
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concrete version of the ISO-7bit language (see Structure of G-function parameters). 

The size of the address panel could be changed by removing its right border. 

This size could be set automatically either by means of the menu command 

«View>Resize>Resize address», or by means of the double mouse click in the 

address panel area, which is not occupied by windows of input fields.  

Table 6. Toolbar keys for the address panel  

Key Purpose 

«F1 Add» Adding an empty line in the current position  

«F2 Del» Deleting the current line 

«F3 Up» Shifting up the lightened line, the step is one line 

«F4 Down» Shifting down the lightened line, the step is one line 

«F5 <<» Shifting one step left the current co-ordinate of the G-vector  

«F6 >>» Shifting one step right the current co-ordinate of the G-vector 

«F7 Teach» Starting the teaching mode 

«F8 Mode» Contra clockwise switching between windows of the text editor, 

the address panel and the ToolBar; «Shift+F8» - clockwise 

switching 

«F9 File» \ «F9 

Abort» 

The transition to the mode of working with files; or exiting the 

program without saving the file, if the parameter -l of the 

command line has been set 

«F10 Exit» Exiting the program 

3.3.1.4 The window of the context graphical help  

The graphical file with reference information is displayed in the window of the 

context graphical help. This information is especially important, when programming 

sophisticated G-functions; such as standard cycles G81-G89, specific for every type 

of the machine-tool. The name of the graphical file is pointed out in the configuration 

file, setting up AdvancEd for the concrete version of the ISO-7bit language (see 

Structure of the G-function’s header). The way of displaying the graphical file in the 

window of the context graphical help could be set up (see The dialogue window, 

intended to set up properties of the window of the context graphical help).  

The size of the window of the context graphical help could be changed by 

removing its top border. This size could be set automatically either by the menu 
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command «View>Resize>Resize image», or by means of the double mouse click in 

the window area.  

3.3.1.4.1 The dialogue window, intended to set up properties of the window of 
the context graphical help 

This dialogue window is used to define the way of displaying graphical file in 

the window of the context graphical help (see זט). The dialogue window could be 

invoked either by the menu command «View>Picture properties», or by the pop-up 

menu by clicking the right mouse button.  

 

Pic. 16. The dialogue window, intended to set up properties of the 
window of the context graphical help 

The radio-button «Autocentre» serves to centre the view in current sizes of the 

window of the context graphical help. The radio-button «Precisely» serves to define 

co-ordinates of the top left angle of the view in the fields «X» and «Y». The scaling 

radio-buttons («No», «Stretch», «Proportional») define the corresponding view 

scaling in the window of the context graphical help. The flag «Scroll» permits 

displaying of scrolling lines; the flag «Border» - permits displaying borders around the 

view.  

3.3.2 Verification of the tool trajectory 

Verification is possible after creating and modifying some flow program in 

AdvancEd (see AdvancEd modes). The corresponding ToolBar appears in the 
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verification mode; and its keys are described in the ז.  

Table 7. ToolBar keys in the verification mode  

Key Purpose 

«F1 Restart» Restarting verification from the beginning of the flow program 

«F2 Edit» Returning to the edit mode 

«F3 Goto» Invoking the dialogue, supporting the transition to a line 

«F4 Show» Switching on-off the view of the tool trajectory 

«F5 Start» Starting the continuos verification process 

«F6 Brk/Next» The transition to the mode of step-by-step verification / The 

next block in the mode of step-by-step verification  

«F7 Stop» Stopping the verification process  

«F8 Skip» Skipping blocks in the verification process  

«F9 Brk.pnt.» Setting breakpoints  

«F10 End» exiting the program 

 

The trajectory, obtained in the verification process, is being displayed in the 

window of the tool trajectory (see The window of the tool trajectory).  

In the process of verification the flow program looks like the high level one with 

corresponding debugging abilities. The process of verification might be either 

continuos, or step-by-step. The menu command «Simulate>Start» starts the 

continuos verification process. the menu command «Simulate>Restart» restarts the 

verification process from the very beginning. The menu command 

«Simulate>Next/Break» starts the step-by-step verification process, realises the 

transition from the continuos process into step-by-step one, verifies the next block in 

the step-by-step process. The menu flag «Simulate>Show» makes it possible to 

switch on-off the tool trajectory view in order to look through concrete parts of the tool 

trajectory.  

The menu flag «Simulate>Incert breakpoint» sets the breakpoint to any flow 

program block in the verification mode (see זי). When the breakpoint is reached the 

verification process halts and could be restarted either step-by-step, or continuously. 

Inasmuch as the ISO-7bit language is interpretative one, it is possible to edit flow 

program blocks after halting the verification process.  

The menu flag «Simulate>Skip» in the continuos verification process switches 
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on skipping blocks and the rapid transition to the nearest breakpoint, or to the end of 

the flow program, if such a breakpoint is absent. If skipping is switched on in the 

step-by step verification process, flow program blocks are not being verified; and this 

makes it possible to verify any parts of the flow program.  

The menu command «Simulate>Stop» is used to stop the verification process.  

In the verification mode there exist additional possibilities: to set up delay 

between verification of neighbour blocks; to create the file of interpolation data (see 

The dialogue window of setups).  

In the verification process the G-vector is being calculated for every block, and 

the result is being presented StatusBar message section (see the Status Bar).  

 
Breakpoints Current position of verification Tool trajectory window

 

Pic. 17. Debugging of the flow program 

3.3.2.1 The window of the tool trajectory 

Results of the verification process are being displayed in the window of the 
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tool trajectory (see זי). The view is 3D, it could be scaled, rotated and moved, using 

either the mouse or the  keyboard.     

There are several regimes to work with the view of the tool trajectory.   

Switching between management regimes is being carried out either by clicking  

the right mouse button, or by using the combination   «Alt» + «M».  

To manage the view, shift the mouse, holding the left button; or use buttons, 

controlling the cursor with the keyboard together with buttons «Alt» and  «Ctrl» (see 

 .(ח

When the regime MOVE is active, there is being displaced the view in the 

screen plane, independently of the coordinate axes position.  When the button «Ctrl» 

has been pushed, the displacement goes on orthogonal to the screen plane; the view 

of the trajectory does  not change, at that; but the axes units are being recalculated. 

When the regime  ROTATE is active, the view is being rotated.  Either when 

moving the view in the vertical direction, or when using  buttons «Alt»+»Up» or 

«Alt»+»Down», the view is being rotated in the vertical plane, orthogonal to the 

screen plane. When the button «Ctrl» is pushed, the view is being rotated in the 

screen plane. When either moving the mouse in the horizontal direction, or using 

buttons «Alt»+»Left» и «Alt»+»Right», - the view is being rotated around the axis Z.   

In all cases rotation takes place together with the  coordinate system.    

In the ZOOM regime the view is being scaled. The view is being increased, 

when the mouse goes down or the buttons «Alt»+»Down» are being pushed. 

Decreasing is being carried out, when the mouse goes up or the buttons    

«Alt»+»Up» are being pushed. 

When the mouse is in the point of the tool trajectory in the edit window, the 

corresponding block of the flow program is being selected in the edit window.     

Parameters or the flow program block are being displayed in the  information 

window. The information window   is able to show the number, values of addresses   

selected block of the flow program, and the current regime  of the flow program and 

the current regime  of managing the view, depending upon the setups in the dialogue 

window (see the dialogue window, intended to setup  parameters of the tool 

trajectory window).   

When the INFO regime is active, there is being carried out the displacement of 

the information window in the limits of the window, showing the tool trajectory. The 

displacement could be realized either by means of the mouse, holding the left button 
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of it at the border of the window; or by means of buttons, controlling the cursor, when 

the  «Alt» button has been pushed. 

Table 8. Keys, controlling the view in the verification regime   

Key combination Action 

  MOVE regime 

«Alt» + «Up» Moving the view up in the screen plane   

«Alt» + «Down» Moving the view down in the screen plane 

«Alt» + «Left» Moving the view left in the screen plane 

«Alt» + «Right» Moving the view right in the screen plane 

«Ctrl» + «Alt» + «Up» Deleting the view 

«Ctrl» + «Alt» + «Down» Bringing the view near 

   ROTATE regime 

«Alt» + «Up», 

«Alt» + «Down» 

Rotating in the vertical plane orthogonal to the screen 

plane    

«Alt» + «Right» Clockwise rotating round the Z axis   

«Alt» + «Left» Counter-clockwise rotating round the Z axis   

«Ctrl» + «Alt» + «Up», 

«Ctrl» + «Alt» + «Down» 

Rotating in the screen plane 

   ZOOM regime 

«Alt» + «Up» Decreasing the view 

«Alt» + «Down» Increasing the view 

   INFO regime 

«Alt» + «Up» Moving the information window up    

«Alt» + «Down» Moving the information window down 

«Alt» + «Left» Moving the information window left 

«Alt» + «Right» Moving the information window right 

 

Fixed positions of coordinate axes are being invoked by the combination of the 

button  «Ctrl» and buttons  «1» - «5». (see  ט). 
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Table 9.  Fixed positions of coordinate axes   

Combination of 
buttons 

Positions of coordinate axes 

«Ctrl» + «1» Isometric - 1 

«Ctrl» + «2» Plane YZ 

«Ctrl» + «3» Plane XZ 

«Ctrl» + «4» Plane XY 

«Ctrl» + «5» Isometric - 2 

 

The window of the tool trajectory has large possibilities to setup view 

parameters (see the dialogue window, intended to setup parameters of the tool 

trajectory window): 

�� measurement units and properties of displayed axes;   

�� visualization quality;   

�� position in the 3D space;   

�� line styles and types for the work and rapid movements;     

�� contents of the information window;   

�� text and line colors;   

�� text fonts.   

3.3.2.1.1 The dialogue window, intended to set up parameters of the window of 
the tool trajectory  

The dialogue window, intended to setup parameters of the tool trajectory 

window, is used to define the way of displaying the trajectory.  This dialogue window 

could be invoked either by the menu command      «View>Emulate Options » or by 

the  double mouse click in the tool trajectory window.  In the process of work with the 

dialogue window in the tool trajectory window there is being shown the test example 

with current setups. The dialogue window includes seven Tabs, grouping setup 

parameters.    . 

The sheet «Axis settings» makes it possible both to choose positions of axes 

for their displaying and to setup their properties (see חי). 

In fields of the group   «Axis мар» there are being shown correspondences of 

axes, displayed at the screen and those, defined in the flow program.   
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Pic. 18. The sheet «Axis settings» 

In the group «Divisions» there are being setup parameters of axes divisions.   

The whole quantity of divisions is being defined in the field «Amount of divisions» It 

should be said, that a lot of divisions  makes the tool trajectory window less 

observable.   

The flag «Enable text» defines the necessity of some values  under axes 

divisions;  and the field  «Fractional signs» points out the precision of the value.   

Values of divisions are being calculated automatically. 

Fields  «Axis line type» and «Axis line width» define the type and the width of 

axes accordingly.  

The list «Measure units» makes it possible to choose the measurement units, 

millimeters or inches.   

The sheet «Rasterization» sets the view quality    (see טי). 



User reference manual Date: 23.09.02  File: AdvancEd User Reference Manual.doc Page:  37 

 

Pic. 19. The sheet «Rasterization» 

The group «Font generation» defines the text parameters. Radio-buttons 

makes it possible to choose the way of displaying the text:   «Polylines» , by means 

of broken lines;   «Polygons», by means of polygons. 

Lists in the group «Smoothness» set the way of smoothing lines   (Line 

smooth), smoothing points (Point smooth) and smoothing polygons (Polygon 

smooth). The field  «Circle accuracy» defines the precision of displaying circles.   

The flag «Depth test» switches on checking of mutual  covering objects.   

The sheet «3D Space» makes it possible to define the position of objects in 

the space (see כ).    

 

Pic. 20.  The sheet "3D Space" 
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The initial coordinates are being defined in the group  «Center of 

coordinates». The button   «Auto» sets these values automatically for every axis, 

depending upon the size of the visualized object.  The flag    «Autocenter» initiates 

calculation and changing coordinates in the process of verification.   

The group   «Rotation» defines angles of rotation of the view (in grades) 

around coordinate axes.   

The field   «Size» sets the scale of the view. The flag «Autosize» and the 

button  «Auto» automatically  change sizes of the view depending upon the visible 

area of the tool trajectory window.   

The sheet «Movements» serves to choose the width and type of lines, 

showing work and rapid movements (see אכ). 

 

Pic. 21. The sheet «Movements» 

From the list «Line type» of the group  «Work movement» there is being 

chosen the type of the line for the work trajectory movement; while in the group   

«Fast movement» there is being chosen the type of the line for the rapid  trajectory 

movement. «Line width» define widths of corresponding lines.   When the flag   «Set 

point« in the group «Point at the end of block» is set, points on the trajectory show 

borders of blocks. The field  «Point width» defines  the size of points. 

The sheet «Info window» sets up the contents of the information window (see 

   .(בכ
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Pic. 22.  The sheet "Info window" 

The flag «Enable info window» switches on the information window. The field 

«Border width» defines the width of the border. 

In the group «Screen position» there is being defined the position of the 

information window. The set of buttons makes it possible to pin the window across 

the edge of the visible area of the tool trajectory window.     

The set of parameters, which are present in the information window, is defined 

by corresponding flags of the group   «Shown parameters» . 

The sheet «Colors» makes it possible to choose the color of any element of 

the tool trajectory window (see גכ).    
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Pic. 23.  The  sheet  «Colors» 

In the list «Property» there should be chose the element of the tool trajectory 

window, for which the color is to be nominated. Such elements could be:    

�� BackgroundColor, the background color of the window;   

�� PointColor, the color of points at the ends of flow program blocks; 

�� WorkMoveColor, the color of the work trajectory movement;   

�� FastMoveColor, the color of the rapid trajectory movement;    

�� RulerColor, the color of the ruler;    

�� GridColor, the color of the grid.    

The color might be set either from the color pallet, or like the color of some 

system element, which is being chosen from the list «System color».    
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In the sheet «Fonts» there could be chosen the type and the way of drawing of 

fonts, intended for signatures under divisions of axes (see דכ).         

 

Pic. 24. The sheet «Fonts» 

3.3.3 Teaching mode  

One of possibilities to create the flow program by means of AdvancEd is to 

use the Teaching mode. The idea is to accept data in the address panel directly from 

the NC system in order to quickly create some flow program block.    

3.3.3.1 Setup  

The setup of AdvancEd should be made before applying the teaching mode. 

The setup consists of  three steps.   

1.  It is necessary to define the TEACH command and its parameters in the 

configuration file.    

2.  It is necessary to identify NC system axes (it will be done automatically).   

3.  It is necessary to identify active axes, used to create the flow program block.    

To use the Teach mode, some changes must be made in the configuration 

file (in case, if the TEACH command has not been defined).    

The definition of the TEACH command looks the same as the definition of 

some usual G-command.   But it is necessary to take into consideration, that the 

name of the TEACH command should be strictly defined as TEACH01. This 

command must belong to the first group, and parameters’ names must strictly 
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correspond to names of NC system axes.   If the name of the command is incorrect, 

the Teach mode is unavailable. If parameters’ names are incorrect, the Teach mode 

is also unavailable; and the corresponding message will appear (see הכ).  

 

Pic. 25 The message about incorrect definition of TEACH-command 
parameters 

At the second step there takes place polling of the NC system and its axes. 

This step is carried out automatically.   

Activation of axes corresponds to the user wish.  During the setup dialogue, it 

is possible to choose parameters, which values will be used in the flow program 

block. By default, all parameters of the NC system are active.    

3.3.3.2 Activation and work 

Activation of the Teach mode could be done both from the menu  «NC 

System>Teaching mode» and from the toolbar by button «F7 Tecah», and by means 

of the hot key  Ctrl+T or F7. 

When activating the Teach mode, there appears the setup dialogue window 

(see וכ), which contains the full set of axes names of the NC system.  If errors of 

axes definition in the configuration file are absent, - all dialogue fields are available 

and all axes are active by default.  The symptom of axes activity is a mark in the 

Check box control element, this mark corresponds to the name of the axis, at that. 

Work in the Teach mode can be supported by the ToolBar.   
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Table 10 Toolbar keys for the teaching mode  

Key Purpose 

«F1 Abs. Zero» Outputting values in the absolute coordinate system 

«F2 Mach Zero» Outputting values in the machinetool coordinate system 

«F3 Rel Zero» Outputting values in the relative coordinate system 

«F4 mm» / «F4 

Inch» 

Choosing measurement units for outputted values 

«F5 Axes Sel» Opening the dialogue window for choosing axes 

«F6 G-Vector» Calculating G-Vector 

«F7 Stop» Stopping the Teaching mode 

«F8 ASCII»  

«F9 Accept» Inputting values into the flow program text. The same as Enter 

«F10 Выход» Exiting the program 

The flow program block is created by means of the clicking «Enter» in the 

address panel. The created block is added to others, and it is displayed in the active 

cursor position in the Edit window.   

Change of the command name, used in the created flow program block, might 

be done from the address panel. The choice of available names is restricted by the 

set of functions, which belong to the first group.   

Changing setups of the mode (choosing active axes) takes place with the help 

of the dialogue, setting up the Teach mode (see וכ). This dialogue is invoked from the 

pop up menu, when clicking the right mouse button or pushing the button  «F5 Axes 

Sel». The mode is delayed, at that, until new setups are defined. After clicking «OK» 

or «Cancel» the mode proceeds. Values of activated axes are inputted into the 

address panel. 

The exit out of the mode could be made either with the help of the menu «NC 

System>Teaching mode», or by means of the hot key Ctrl+T of the address panel, or 

by toolbar button «F7 Stop». 
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3.3.3.3 Setup dialogue of the Teaching mode 

Inactive axis Active axis

 

Pic. 26 The setup dialogue of the teaching mode 

The setup dialogue of the Teaching mode provides the definition of user 

setups of the Teaching mode and informs the user about setup problems, which 

might appear.   

The dialogue displays axes names of the NC system. Active axes names are 

marked. Deactivated axes notify about an error in the configuration file.    

When clicking the button  «ОК» all user setups will be saved. In case, if the 

button «Cancel» is clicked, all current user setups will not be saved; but there will be 

applied those, defined earlier.   

3.4 Viewing files with interpolator data 

To view the contents of files with interpolator data, there is used the similar 

window of the tool trajectory, like in the verification mode (see Verification of the tool 

trajectory). In the view mode (see AdvancEd modes), there appears the 

corresponding ToolBar with keys, described in the אי.  
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Table 11. Keys of the mode, intended to view files with interpolator data  

 Key Purpose 

«F1 Restart» Restarting the view from the beginning of the file with 

interpolator data  

«F4 Show» Switching on-off the view of the tool trajectory  

«F5 Go» Starting the continuos view process  

«F6 Brk/Next» Switching to the step-by-step view / The next block is in the 

step-by-step view mode  

«F7 Stop» Stopping the view process 

«F10 End» Exiting the program 

The view process, like the process of verification, could be either continuos, or 

step-by step one. The menu command «Simulate>Start show IPD file» starts the 

continuos view process; the menu command «Simulate>Restart» realises restart 

from the beginning of the file. The menu command «Simulate>Next/Break» starts the 

step-by-step, initiates the transition from the continuos process into step-by-step one, 

realises the view of the next block in the step-by-step process. Just like in the 

verification process, in the interpolator-data-file view process, there is invoked the 

dialogue window, intended to set up parameters of the window of the tool trajectory. 

The dialogue window could be invoked either by the menu command «View>Emulate 

options», or by means of clicking the right mouse button in the window of the tool 

trajectory.  

3.5 Starting external applications 

AdvancEd allows the user to define up to sixteen external applications, which 

could be started from the menu  «Tools». The first and the last points of this menu 

(«Tools>Cfg Editor» and «Tools>Customise») are rigid; they are used both to invoke 

the editor of  configuration files and to set up the menu. The points, which are being 

added by the user, these points are located between the first and the last points and 

might have any names. 

3.6 Getting reference information  

AdvancEd suggests two kinds of help; the first is reference one, the second is 

context one.  
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The reference help presents itself to be the electronic version of this very 

reference manual. The contents of the reference help could be invoked by the menu 

command «Help>Help Topics». The chapter of the reference help, describing the 

main abilities of AdvancEd, could be invoked by the menu command «Help>Help 

Index». The menu command «Help>Help Using» invokes the description of the 

reference-help sub-system, as well as methods of getting reference information.  

The context help could be delivered in pop-up or overlapped windows in order 

to describe: the purpose of some concrete window, menu commands, ToolBar keys, 

dialogue elements. In case of error message or warning message (see זכ) the 

context help suggests the detailed description of the arose problem and receipts to 

overcome it. The context help could be got in the following ways.  

1. For the window: 

1.1. Push the key combination «Ctrl+F1», being located in the window, for which 

the reference is necessary.  

1.2. Go to the regime «?» by means of the key combination «Shift+F1» and 

choose the window.  

2. For the dialogue element:  

2.1. Push the key «F1» or the key combination «Ctrl+F1», removing yourselves 

preliminary to the corresponding dialogue element.  

2.2. Go to the regime «?», pushing the question mark in the top right angle of the 

dialogue window and choose the corresponding element.  

3. For the menu command or the ToolBar: 

3.1. Go to the regime «?» by means of the key combination «Shift+F1» and 

choose the command or the Toolbar.  

4. For the message window:  

4.1. Push the key «Help». 

4.2. Push the key «F1» 

 

Pic. 27. The error message window 
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4. Possible setups of AdvancEd 

4.1 Setting up AdvancEd parameters 

The following parameters of the current edit session are being saved in the 

special initialisation file, when exiting AdvancEd: 

�� sizes both of the address panel window and context help window;  

�� the contents of fields, states of radio-buttons and flags for all dialogues;  

�� states of regimes of the full-screen editor and the editor with the address 

panel.  

�� parameters of a printing. 

Starting AdvancEd, there is undertaken an attempt to read mentioned 

parameters from the initialisation file. If this file is absent, or if file parameters are 

absent, or if file parameters are wrong, - values of parameters are nominated by 

default. 

The name of the initialisation file coincides with the name of the AdvancEd 

executive module (see the Short description of  AdvancEd files). 

4.1.1 The dialogue window of setups 

In the special dialogue window some setups could be defined, besides those, 

which belong to the edit session in AdvancEd (see חכ). 

The number of blanks, which are to be inserted into the current cursor 

position, when pushing the key «Tab» in the edit window (see the Text editor), - this 

number should be inputted into the field «Tab size». The field «Delay, ms» of the 

group «Simulation» defines the delay time in milliseconds between verification of 

neighbour blocks in the process of continuos verification.  

The fields «The number of points for the equidistant correction» and  «The 

tool radius for the equidistant correction»  define the number of blocks, which are 

analyzed in the process of the equidistant correction, and the tool radius accordingly. 

The flag «Make ipd file» defines creation of the interpolation data file; the 

name of this file coincides with the name of the edited file, but has the extension .ipd 

(see Verification of the tool trajectory).  

The flag «Make bak file» finds out, whether there is created the insurance 

copy of the file, being opened. 
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The group of radio-buttons «Language» make it possible to choose the 

language of the user interface; if there exist dll files, containing corresponding menu 

resources, dialogue and message resources. To change the language, it is 

necessary to restart the system.  

The field «CFG file» shows the name of the file, setting up AdvancEd to the 

concrete version of the ISO-7bit language (see Review of the open DIN language). 

The key «Apply» or the key «OK», closing the dialogue, initiate fixing all 

setups in the initialisation file.  

 

Pic. 28. The dialogue window of setups 

4.1.2 Setting up the menu, starting external applications 

In the menu «Tools» of AdvancEd there exists a possibility, using a special 

dialogue, - to add up to sixteen points, intended to start external applications. When 

adding a new point, there should be defined its name, the full path to the file of the 

external application, the work catalogue and the list of additional arguments, if 

necessary.  

4.1.2.1 The dialogue window, intended to set up the menu of starting 

external applications 

This dialogue window (see טכ) is being invoked by the menu command  
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«Tools>Customize»; it is intended to define the contents of the menu  «Tools». 

The button «New» adds a new menu point, the button «Delete» deletes the 

point, created earlier.  The buttons  «Up» and «Down» make it possible to change 

the succession of inputted points.  If the name has not been defined for some new 

point, this point will not be created. If the point name has been deleted, this point will 

be deleted.   In the edit field «Command:» the name of the external application file 

should be defined.  If necessary, to fill this field, there could be used a window, 

intended to search the file with the help of navigation; this window might be invoked 

by the button, which is respectively right to the field.    

The edit field  «Arguments:» is not necessary; it could contain the list of 

arguments, being transmitted to the external application at its start.   

The edit field  «Initial directory:» contains the path, which is the work one for 

the external application. If the value is absent in this field, the current catalogue is  

nominated to be the work one. 

 

Pic. 29 The dialogue window, intended to set up the menu of starting 
external applications 

4.1.3 The format of the initialisation file 

The initialisation file is intended to save current values of setups and set up 

parameters of AdvancEd. This file is a text one, consisting of titles of sections, 

parameters and comment. The title of the section is included into the square 

brackets «[ ]». Each title of the section and parameter require the separate line. The 

length of lines should not exceed 256 symbols. All parameters are being written 

down into the initialisation file to the extent of either their altering in dialogue windows 
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or at changing AdvancEd modes. In this connection it is possible to change them 

manually only in the extraordinary situations.  

All section titles of the AdvancEd initialisation file are submitted in the בי.  

Table 12. Sections of the initialisation file 

Section Description 

[Settings] General settings of AdvancEd 

[Display] Sizes both of the address panel window and the window of 

the context graphical help  

[PicturePropertiesDlg] Settings of properties of the window of the context 

graphical help  

[Text_editor] Settings of the text editor 

[TeachDlg] Setting of teaching mode 

[Emulate] Settings of the window, intended to visualise the tool 

trajectory  

[GotoDlg] State of elements of the dialogue window, supporting 

transition to a line; these elements are those, used in the 

last transition  

[SearchDlg] State of elements of the dialogue window, supporting 

search-replace; these elements are those, used for the 

last search-replace operation 

[ScaleDlg] State of elements of the dialogue window, supporting 

scaling; these elements are those for the last scaling 

operation  

[RenumDlg] State of elements of the dialogue window, supporting re-

numeration of blocks; these elements are those, used for 

the last re-numeration operation  

[Recent File List] List of last ten opened files in AdvancEd  

[Tools] List of the point of the menu   «Tools» 

 

The format, descriptions and permitted values of parameters in sections of the 

initialisation file, - are submitted in the גי.  
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Table 13. Parameters if the initialisation file 

Parameter Value Description 

Section [Settings] 

sCfgFile C:\CFG\MY_CFG.CFG The name of the file, setting up 

AdvancEd for the concrete version 

of the ISO-7bit language 

m_iAngleX0 

m_iAngleY0 

m_iAngleZ0 

m_iAngleX1 

m_iAngleY1 

m_iAngleZ1 

m_iAngleX2 

m_iAngleY2 

m_iAngleZ2 

m_iAngleX3 

m_iAngleY3 

m_iAngleZ3 

m_iAngleX4 

m_iAngleY4 

m_iAngleZ4 

300 

0 

220 

270 

0 

270 

270 

0 

0 

0 

0 

0 

300 

0 

300 

Angles, which define 5 directions 

of view in simulation window 

sWorkPath C:\NCS\ The default path at loading flow 

program files and files of 

interpolation data  

bMakeBakFile 1 The directive, whether the *.bak 

file of the flow program should be 

created (1 - yes, 0 - no) 

sLanguage Eng The prefix, used to formulate 

names of files of dynamic libraries  

(NcEdtCOMResEng.DLL, 

NcEdtCOMResGer.DLL, 

NcEdtCOMResRus.DLL, 

MFC42Ger.DLL, MFC42Rus.DLL), 
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these libraries contain localised 

resources of the user interface       

(Eng - English, Ger - German, Rus 

- Russian). 

SblockPath C:\NCS\ The default path, used to load 

blocks from files  

bSimulateMode 1 Indication, whether the simulation 

mode is available:  (1 - available;  

0 - unavailable) 

iPageLeft 

iPageTop 

iPageRight 

iPageBottom 

2500 

2500 

2500 

2500 

Values of margins, when printing 

the document 
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Parameter Value Description 

Section[Display] 

iAddressWidth 222 The width of the address panel [in pixels]  

(51 .. 699) 

iPictureHeight 195 The height of the window of the context 

graphical help [in pixels](51 .. 396) 

bWatch 1 Edit mode  

(0 - the full-screen text editor; 1 - the editor 

with the address panel and the context 

graphical help)  

Section [PicturePropertiesDlg] 

m_bScroll 1 Presence of the scrolling lines in the window of 

the context graphical help (1 - yes, 0 - no) 

m_sXpos 50 The horizontal co-ordinate of the top left angle 

of the view in the window of the context 

graphical help [in pixels] (0 .. 65535) 

m_sYpos 50 The vertical co-ordinate of the top left angle of 

the view in the window of the context graphical 

help [in pixels] (0 .. 65535) 

m_iZoom 0 The way of scaling the view in the window of 

the graphical help (0 - without scaling; 1 - fit 

into the window; 2 - fit into the window 

proportionally)  

m_iPos 1 The way of positioning the view in the window 

of the graphical help (0 - in accordance with 

values m_sXpos and m_sYpos; 1 - auto-

centring) 

m_bBorder 1 Presence of the border around the view in the 

window of the graphical help (1 - yes, 0 - no) 
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Parameter Value Description 

Section [Text_editor] 

m_bCorrectSyntax 1 Switching on the automatic syntactical 

correction, when inputting blocks by means of 

the editor address panel (1/0, 1 - yes, 0 - no) 

bInsert 1 State of the insertion-substitution mode: (1 - 

insertion, 0 - substitution) 

iTab_size 3 Number of blanks, included at clicking the 

button     "Tab" 

Section [TeachDlg] 

m_iPosDataType 0 Position of an origin of coordinates (0 - 

Absolute, 1 - Relative, 2 - Machine) 

m_bMM/INCH 1 Units of measurements 

X, Y, Z, A, ... 1 State of an appropriate axis (1 - Active / 0 - 

Inactive) 

Section [Emulate] 

m_bSimulateSkip 1 Skipping flow program blocks during the 

verification process (1 - yes, 0 - no) 

m_iSimulationDelay 1 Delay in milliseconds between verification of 

neighbour blocks (1 ... 2147483647) 

bMakeIPDFile 1 The directive, whether the IPD file should be 

created during the verification process (1 - yes, 

0 - no) 

ulBackgroundColor 16777215 The background colour of the window, 

intended to display the tool trajectory (0 ... 

4294967295) 

lWkLine 0 The type of the line, simulating the work 

movement (0 ... 4) 

ulWorkMoveColor 0 The colour of the line, simulating the work 

movement (0 ... 4294967295) 

lFstLine 2 The type of the line, simulating the rapid 

movement (0 ... 4) 

ulFastMoveColor 16711680 The colour of the line, simulating the rapid 
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movement (0 ... 4294967295) 

lNameXAxis 1 The number of the horizontal axis (0 ... 15) 

lNameYAxis 3 the number of the vertical axis (0 ... 15) 

lMeasureType 1 Measure units (1 - inches; 0 - millimetres) 

dGridDivisions 0.393701 The grid step 

Parameter Value Description 

dYsizeMIN 0.000000 The minimal value along the vertical axis 

dYsizeMAX 4.724409 The maximal value along the vertical axis 

dRulerDivisions 0.393701 The step of the ruler 

bRulerState 1 The directive, whether the ruler should be 

shown (1 - yes, 0 - no) 

bAutoResize 1 The directive, whether the horizontal axis 

should be fit into the window (1 - yes, 0 - no) 

bGridState 1 The directive, whether the grid should be 

shown (1 - yes, 0 - no) 

ulRulerColor 0 Ruler colours (0 ... 4294967295) 

ulGridColor 32768 Grid colours (0 ... 4294967295) 

lWkLineFit 0 The width of the work movement line (0...100) 

lFstLineFit 0 The width of the rapid movement line (0...100) 

bPointState 1 The directive, whether the points between 

neighbour blocks should be shown (1 - yes, 0 - 

no) 

ulPointColor 255 The colour of points between neighbour blocks 

(0 ... 4294967295) 

bEnableText 1 The directive, whether the ruler text should be 

shown (1 - yes, 0 - no) 

bNoFractional 0 The directive, whether fractional parts in the 

ruler text should be shown (1 - yes, 0 - no) 

dXsizeMIN 0 The minimal value along the horizontal axis  

dXsizeMAX 6.299213 The maximal value along the horizontal axis 

m_iSizeEQBuffer 4 The number of blocks, which are to be 

analyzed during the equidistant correction 
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Parameter Value Description 

Section [GotoDlg] 

m_iAbsolut 1 The type of the transition to a line (1 - 

relative; 0 - absolute)  

m_iGotoDown 1 The direction of the transition (1 - to the 

file end; 0 - to the beginning of the file)  

m_iLineNum 200 The line number 

Section [SearchDlg] 

m_cComboFindString0 

 ... 

m_cComboFindString32 

string1 The list of last 32 lines, used in the search 

session  

m_cComboReplaceString0 

 ... 

m_cComboReplaceString32 

string2 The list of last 32 lines, used for replacing 

in search-replace sessions  

m_iCase 1 The directive, whether the register should 

be taken into consideration during the 

search process (1 - yes, 0 - no) 

m_iSearchDown 1 The search direction (1 - to the file end; 0 

- to the beginning of the file)  

m_lNumberOccurrences 20 The number of insertions of the sought 

line 

m_iAll 1 The directive, whether all insertions 

should be handled (1 - yes, 0 - no) 

m_iAsk 1 The directive, whether replaces should be 

confirmed (1 - yes, 0 - no) 

m_iWord 1 The directive, whether the full word 

should be searched (1 - yes, 0 - no) 

m_iReplace 1 The directive, whether the found 

insertions should be replaced (1 - yes, 0 - 

no) 
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Parameter Value Description 

Section[ScaleDlg] 

m_iFromPos 1 Initial units of scaling (0 ... 3) 

m_iToPos 3 Target units of scaling (0 ... 3) 

m_dScaleFactor 0.001 The scaling coefficient  

m_adScaleFactors[0] 

 ... 

m_adScaleFactors[3] 

1.0000 

 

25.400 

The scaling coefficient between first 

(second, third, forth) units  

Section [RenumDlg] 

m_iStart 1 The number, starting re-numeration 

m_iStep 1 The step, starting re-numeration  

Section [Recent File List] 

File1 

 ... 

File10 

C:\NCS\1.NCS 

 

C:\NCS\10.NCS 

The name of the last opened file 

Item [Tools] 

MenuName0 

  ... 

MenuName15 

Tool0 

 

Tool15 

The name of the point of the menu  

«Tools», used to start the 

corresponding external program.     

InitialDirectory0 

  ... 

InitialDirectory15 

C:\Tool0 

 

C:\Tool15 

The name of the directory, which is 

the work one for the external 

program.   

PathName0 

  ... 

PathName15 

C:\Tool0\tool0.exe 

 

C:\Tool15\tool15.exe 

The name of the execution file of the 

external program.   

DefaultArguments0 

  ... 

DefaultArguments15 

/Arg1 /Arg2 

 

/Arg1 /Arg2 

Arguments, being transmitted to the 

execution file of the external program.  

4.1.3.1 Using comment 

It is possible to use lines-comment in the initialisation file. The line-comment 

begins with the symbol «;». When reading the initialisation files, the lines-comment 

are being ignored.  
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4.2 Setting up the current version of the DIN 66025 (ISO 6893) 

language 

4.2.1 Review of the open DIN language 

The idea of the open DIN language means, that any version of DIN 66025 flow 

program language might be formalised according to some definite set of rules. 

The basic thing is to set apart algorithmic functions of the flow program block 

and data structures of the block. Algorithms are represented mainly by preparatory 

functions, i.e. G-functions. Data structures are represented by displacement 

functions (X, Y, Z, I, J, K, R), by the feedrate function (F), by the speedrate function 

(S). Data structures should be narrated like G-functions’ parameters, while G-

functions themselves should be considered to be a set of commands of some virtual 

DIN-machine. The next important thing is to divide G-functions into some orthogonal 

groups. Each group means some certain functionality of its G-functions. The proper 

structure, with its special format (described in the די and Structure of the G-function’s 

header), belongs to the concrete group of the commands’ set.  

Table 14 

Field Purposes 

Group index  Group number  

Modality symptom  It defines, whether the group influences the system state, i.e. 

G-vector 

Command activity  It defines, whether the command is active by default 

 

This structure, together with the graphic presentation file name, forms the 

header of the G-function in the *.cfg file. 

The body of the G-function description consists of the list of parameters, i.e. 

the list of addresses, connected with the definite G-function. Each element of the list 

includes into itself the address name, minimum and maximum values, the address 

format, and the position of the address window in the address panel. 

The next formalising step means definition of delimiters, comment, axes’ 

names, addresses’ names, G-functions’ names. The corresponding lists should be 

defined for the DIN 66025 version as a whole, but not for the concrete G-function. 
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4.2.2 Description of CFG-file format 

Configuration file describes the structure of the address panel, intended to edit 

the G-function, and also contains information about some concrete grammar version 

of the DIN 66025 language. Configuration file has a rigid format, which is described 

below. 

CFG-file is a text one, consisting of options, sections, devoted to G-functions, 

and comment. For each option, header of the G-function and parameter of the G-

function it is necessary to allocate separate line.  

Length of CFG file line should not exceed 256 characters. 

4.2.2.1 Options 

The following parameters might be set as options for this version of the DIN 

language 66025: 

�� properties of the configuration file; 

�� the comment; 

�� delimeters; 

�� the set of possible names of G-functions; 

�� the set of possible names of addresses of G-functions; 

�� the set of possible names of axes of G-functions; 

�� the set of possible parameters’ names of g-functions. 

The format of options is submitted in the וט. 
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Table 15 

Parameter Value Description 

Delimiters « \r\t\n,<>» The list of conceivable delimiters 

Comment «%*;» The list of conceivable comment 

Address «N M S T F I J K R» Sequence of lines, separated by blanks, 

which defines a set of possible G-function 

addresses’ names  

Axis «X Y Z A B C» Sequence of lines, separated by blanks, 

defining a set of possible names of axes of 

G-functions 

Functions «G» Sequence of lines, separated by blanks, 

defining a set of possible names of G-

functions 

Parameters « N= » Succession of lines, separated by blanks, 

defining a set of possible parameters’ 

names of g-functions 

Title File title The title of the file 

Author File author The author (authors) of the file 

File_Comments File comment  The comment to the file 

Company STANKIN NCs The company-developer of the file 

NC_type Type of NC system The type of the NC system 

 

The G-functions names, which are not included into the options «Functions», 

are ignored by the system. Addresses and the axes, which are not included into 

options «Address» and into options «Axis», are accordingly ignored when converting 

files, scaling and re-numerating. 

The option «Parameters» describes addresses, which values are lines. Such 

addresses are parameters of G-functions, invoking sub-programs and macros. 

Names of such addresses should obligatory be followed by the symbol «=». 

4.2.2.2 Structure of the G-function’s header 

The header consists of successively enumerated (in any order) options and 

their values, divided by generalised blanks; see the זט. 
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Table 16. Options of the G-function header 

Header 
options 

Value Description 

G 00 Function name is a sequence of one letter and 

any three digits 

graphic BMP\G00.BM

P 

Full name with a path of the view file, 

corresponding to the function - up to 240 

symbols 

modal 1 Unmodal/modal function, (0/1) 

default 0 Inactive/active by default, (0/1) 

groupindex 0  Number of the group (0-31) 

 

When *.bmp-file is being created, - it is better to use 256 colors. 

While creating the CFG-file, - it is necessary to describe the unmodal 

(modal=0) G-function, without pointing out the value header for G-option, and with 

the parameter, groupindex=0. This G-function will be reflected by default, i.e. the 

description of this G-function parameters will define addresses, being displayed in 

the address panel, if G-functions are missing in the current line of the text editor. 

4.2.2.3 Structure of G-function parameters 

A list of G-function’s parameters defines: 

�� possible addresses; 

�� the layout of address windows in the address panel. 

The succession of parameters’ set defines the succession of addresses in the 

flow program block, when transforming the block into the standard form. It also 

defines the succession of   addresses values, when inputting the block into the 

address panel. Every G-function parameter submits a sequence of successively 

enumerated attributes, divided by colons. The parameter format is shown in the זי. 
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Table 17 

 Values of attributes Description 

: Y Parameter name 

: Line axis Comment, which will be displayed in StatusBar 

: v999.99 The parameter format; v-designates presence of the 

sign, an amount of digits 9 designate an amount of bits 

accordingly before and after a comma 

: -999.99/999.99 Range of parameter values: min/max. 

: 0.5 X-co-ordinate of parameter position at the screen, - float 

: 2 Y-co-ordinate of parameter position at the screen, -float 

:T 000,000,000/ 

192,192,195 

Colour in the RGB format, used to display the parameter 

name at the screen: foreground/background, - 

(000,000,000/255,255,255) 

:C 000,000,000/ 

255,255,255 

Colour in the RGB format, used to display the parameter 

edit line at the screen: foreground/background - 

(000,000,000/255,255,255) 

 

To define the parameter like exception for the given G-function, its name 

could be shown parenthetically, for instance  «(N)» or «(Y)». The exception means 

the following:  

�� if the parameter’s name is «N», then it is being ignored at re-numeration;   

�� if the parameter’s name is mentioned in the «Address» option, then it is 

being ignored at scaling. 

If one G-function  describes parameters with the same names (the first is an 

address, another is an exception; for instance: N10 G95 N20), it should be done the 

following. The description of the first parameter in the parameter’s list should 

precede the description of the parameter, the name of the function (normally - «G»); 

while the description of the second parameter should follow it. 

Example: 
G95   graphic=..\pcx\g95_e.pcx modal=1 default=0 groupindex=14 

:N    :Block number                      :9999999     :0/9999999                :11.25 :1    :T000,000,000/198,198,198 :C000,000,000/255,255,255 

:G    :Time programming (k/min.) :99               :0/99                          :11.25 :1    :T000,000,000/198,198,198 :C000,000,000/255,255,255 

:(N)  :Multiplication factor             :v99999.99  :-99999.99/99999.99 :0.25   :7    :T000,000,000/198,198,198 :C000,000,000/255,255,255 
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For addresses, pointed out in the list   «Parameters», there is used another 

format of attributes, shown in the חי. 

Table 18 

 Value of the 
attribute 

Description 

: N= the name of the parameter 

: Macro name the comment, being shown in the  StatusBar 

: ############## the format of the parameter; the number of   "#" symbols 

corresponds to the maximal quantity of symbols in the value 

of the parameter    

: 0.5 X-co-ordinate of parameter position at the screen, - float 

: 2 Y-co-ordinate of parameter position at the screen, -float 

:T 000,000,000/ 

192,192,195 

Colour in the RGB format, used to display the parameter 

name at the screen: foreground/background, - 

(000,000,000/255,255,255) 

:C 000,000,000/ 

255,255,255 

Colour in the RGB format, used to display the parameter 

edit line at the screen: foreground/background - 

(000,000,000/255,255,255) 

If the parameter’s name is not described in options «Address», «Axis», 

«Functions», «Parameters», then attributes, defining the scope and format of this 

parameter are being ignored; and the address panel displays only its name 

4.2.2.4 The full number of G-function sections 

Here only an example of the section for G93 function has been presented. 
G93 graphic=bmp\g93.bmp modal=1 default=0 groupindex=13 

:N :Block number :99999 :0/99999 :0.5 :2 :T000,000,000/198,198,198 :C000,000,000/255,255,255 

:G :Function number :99 :0/99 :12 :2 :T000,000,000/198,198,198 :C000,000,000/255,255,255 

Sections for other G-functions are the same. 

4.2.2.5 Using comment 

Comment could be used in the CFG file with the help of symbols either «//» or 

«;». In string values, closed by quotation marks, comment does not work and are 

perceived like string elements. Example: 
// this is a comment 
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:N :Block number :9999 :0/9999999 :0.5 :2 :T000,000,000/198,198,198 :C000,000,000/255,255,255 ;this is a comment 

Comment="%;*" (in this case ";" - is not a comment, but a value). 

5. Description of warnings and error messages 

Warnings and error messages of AdvancEd are appearing in corresponding 

windows (see זכ); and crucial messages are being written down in the special file 

error.log with time and data of the error. The description of warnings and error 

messages of AdvancEd, and methods of error treatment is submitted in the טי.  
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Table 19 

Warning or error 
message 

Restart the program to finish operations, intended to change 

the language 

Methods of 
treatment 

Restart the program, make sure, that the resource DLL exists 

for the chosen language  

(For English - NcEdtCOMResEng.dll,  

 for German - NcEdtCOMResGer.dll,  

 for Russian - NcEdtCOMResRus.dll) 

  

Warning or error 
message 

The error of reading the graphical file: DIB is too large 

Methods of 
treatment 

Check correctness of the DIB or BMP file, decrease its 

volume, if necessary  

Warning or error 
message 

The error of reading the graphical file: unknown graphical 

format 

Methods of 
treatment 

Check the format of the graphical file; at error create the file 

anew or restore it from the reserve copy; if the file format is 

not DIB, BMP or WMF, - convert into one of such formats 

  

Warning or error 
message 

The error of reading the graphical file: impossible to read the 

contents of the DIB-file title 

Methods of 
treatment 

Check correctness of the DIB or BMP file; at error create the 

file anew or restore it from the reserve copy  

  

Warning or error 
message 

The error of reading the graphical file: the reason is described 

by the operating system 

 Methods of 
treatment 

Check the format and integrity of the graphical file and 

absence of errors in the hard disk; at error create the file 

anew or restore it from the reserve copy 

  

Warning or error 
message 

The error of reading the graphical file: it is impossible to read 

the contents of the DIB-file 
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Methods of 
treatment 

Check correctness of the DIB or BMP file; at error create the 

file anew or restore it from the reserve copy 

  

Warning or error 
message 

The line can not be longer than 1024 symbols 

Methods of 
treatment 

Decrease the line length in the text editor  

  

Warning or error 
message 

Wait for the end of the operation 

Methods of 
treatment 

Wait for the finish of the current operation; in case of coercive 

finish of the program, - data will be lost  

  

Warning or error 
message 

The error of opening the *.cfg file: the reason is described by 

the operating system 

Methods of 
treatment 

Check the format and integrity of the configuration file, and 

absence of errors in the hard disk; at error create the file 

anew or restore it from the reserve copy 

  

Warning or error 
message 

The error of initialising OLE 

Methods of 
treatment 

Reset the program; in case of repeat - reset the whole 

operating system  

  

Warning or error 
message 

The scaling coefficient is wrong 

Methods of 
treatment 

Correct the value of the scale coefficient  

  

Warning or error 
message 

The error of reading WMF file, the reason is: the error of 

creating the file reflection in the RAM memory 

Methods of Check the size and correctness of the WMF file; if necessary 
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treatment - restore from the reserve copy; free the memory, unloading 

applications, not used  

  

Warning or error 
message 

The error of reading WMF file, the reason is: the error of 

reflecting the object in the RAM memory 

Methods of 
treatment 

Check the size and correctness of the WMF file; if necessary 

- restore from the reserve copy; free the memory, unloading 

applications, not used 

  

Warning or error 
message 

The error of reading WMF file, the reason is described by the 

operating system (SetWinMetaFileBits failed) 

Methods of 
treatment 

Check the size and correctness of the WMF file; if necessary 

- restore from the reserve copy  

  

Warning or error 
message 

The error of reading WMF file, the reason is described by the 

operating system (SetWinMetaFileBitsEx failed) 

Methods of 
treatment 

Check the size and correctness of the WMF file; if necessary 

- restore from the reserve copy 

  

Warning or error 
message 

The error of reading WMF file, the reason is described by the 

operating system (GetMetaFile failed) 

Methods of 
treatment 

Check the size and correctness of the WMF file; if necessary 

- restore from the reserve copy 

  

Warning or error 
message 

The error of reading WMF file, the reason is described by the 

operating system (GetMetaFileBitsEx failed) 

Methods of 
treatment 

Check the size and correctness of the WMF file; if necessary 

- restore from the reserve copy 

  

Warning or error 
message 

The error of allocating the memory, while reading the WMF 

file, the reason is described by the operating system 

Methods of Decrease the size and check correctness of the WMF file; if 
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treatment necessary - restore from the reserve copy; free the memory, 

unloading applications, not used  

  

Warning or error 
message 

The error of creating the temporary file, the reason is 

described by the operating system 

Methods of 
treatment 

Treat the reason of the error in accordance with description of 

the operating system. Check correctness of setting the 

system variable «TEMP»; check availability of path, to which 

it points out; check free area at the disk, along this path  

  

Warning or error 
message 

The error of creating the *.bak file, the reason is described by 

the operating system 

Methods of 
treatment 

Treat the reason of the error in accordance with description of 

the operating system. Check free area in the disk, where the 

edited file had been opened  

  

Warning or error 
message 

The group of G-functions is wrong, the given function is 

absent in the group under the corresponding number 

Methods of 
treatment 

Correct the number of the G-function in such a way, that the 

number substitution should be carried out inside the group of 

the current G-function  

  

Warning or error 
message 

The number of the G-function is wrong 

Methods of 
treatment 

Substitute the number of the G-function for one, described in 

the configuration file of G-functions  

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the symbol ":" 

is not found in the line 

Methods of 
treatment 

Correct the description of the parameter of the G-function in 

the corresponding line of the configuration file  
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Warning or error 
message 

The error of reading the *.cfg file, the reason is: the symbol "/" 

is not found in the line 

 Methods of 
treatment 

Correct the description of the parameter of the G-function in 

the corresponding line of the configuration file  

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the sub-line 

":T" is not found in the line 

Methods of 
treatment 

Correct the description of the parameter of the G-function in 

the corresponding line of the configuration file  

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the sub-line 

":C" is not found in the line 

 Methods of 
treatment 

Correct the description of the parameter of the G-function in 

the corresponding line of the configuration file  

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the symbol "," 

is not found in the line 

Methods of 
treatment 

Correct the description of the parameter of the G-function in 

the corresponding line of the configuration file  

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the sub-line 

"graphic=" is not found in the line 

Methods of 
treatment 

Correct the description of the header of the G-function in the 

corresponding line of the configuration file  

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the sub-line 

"modal=" is not found in the line 

Methods of 
treatment 

Correct the description of the header of the G-function in the 

corresponding line of the configuration file 

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the sub-line 

"default=" is not found in the line 
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Methods of 
treatment 

Correct the description of the header of the G-function in the 

corresponding line of the configuration file 

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the sub-line 

"groupindex=" is not found in the line 

Methods of 
treatment 

Correct the description of the header of the G-function in the 

corresponding line of the configuration file 

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the value of 

the parameter "Functions=" is not defined 

 Methods of 
treatment 

Add or correct the description of the parameter "Functions=" 

in the configuration file 

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the value of 

the parameter "Address=" is not defined 

Methods of 
treatment 

Add or correct the description of the parameter "Address=" in 

the configuration file 

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the value of 

the parameter "Axis=" is not defined 

Methods of 
treatment 

Add or correct the description of the parameter "Axis=" in the 

configuration file 

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the value of 

the parameter "Delimiters=" is not defined 

Methods of 
treatment 

Add or correct the description of the parameter "Delimiters=" 

in the configuration file 

  

Warning or error 
message 

The error of reading the *.cfg file, the reason is: the value of 

the parameter "Comment=" is not defined 

Methods of 
treatment 

Add or correct the description of the parameter "Comment=" 

in the configuration file 
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